[Sunbeam Talbot Email List] Sunbeam Alpine MKI Crankshaft Oil Guard

Don Ingram din1022099 at aol.com
Mon Dec 12 21:03:22 EST 2016


I have also had good success with " metal spray" on the seal surface wear area. Find a machine shop that offers the service if a speedy sleeve of correct size cannot be found
Don Ingram



Sent from my Verizon, Samsung Galaxy smartphone
-------- Original message --------From: PETER WOODALL <starcars8 at comcast.net> Date: 12/12/16  5:47 PM  (GMT-08:00) To: Staowners <staowners at sunbeamtalbot.info>, J W <im1neng at gmail.com> Subject: Re: [Sunbeam Talbot Email List] Sunbeam Alpine MKI Crankshaft Oil Guard 
That's the one. There shouldn't be a serious leak without it but by the same token it should be installed. I hope that the machine shop checked the oil seal land on the pulley,that's where the seal contacts the pulley, to make sure that it's not "grooved". If it is get a "speedy sleeve installed. That's a really thin sleeve that is pressed over the oil  seal land to create a new surface for the seal to run on. When reassembling fit the timing cover loosely, install the crank pulley and then tighten the timing cover bolts. This tends to centre the seal on the pulley. Need more info? you know where I am.  PeteOn December 12, 2016 at 5:02 PM J W <im1neng at gmail.com> wrote:

With the initial start of my 1954 Sunbeam Alpine MKI engine, I noticed a decent leak from the front crankshaft seal in the timing cover.  Given the fact that I purchased a new seal to be installed, I went searching in the Parts Manual for a possible source of the leak.  It looks like there should be an oil guard between the fan pulley and the crankshaft timing wheel.  I searched through the parts that I received back from the engine builder, I found a part that may be the oil guard that I noted in the Manual.
I've attached a file that shows the Parts Manual drawing as well as a couple of pics of the part I found in my bin. 
Can anyone verify that the part I found is actually the crankshaft oil guard?  If this is the oil guard, it was obviously not installed on my engine and probably a key factor to my leak.
Thanks!Jo
 _______________________________________________
Staowners mailing list
Staowners at sunbeamtalbot.info
http://sunbeamtalbot.info/mailman/listinfo/staowners_sunbeamtalbot.info
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://sunbeamtalbot.info/pipermail/staowners_sunbeamtalbot.info/attachments/20161212/db76c115/attachment.html>


More information about the Staowners mailing list